element ui 自定义主题遇到的问题

执行et -i时报错primordials is not defined,需要改node版本到11.5.0,可以使用nvm安装nvm install 11.5.0

之后再执行,有一个关于node-sass的报错,直接rebuild

cd /usr/local/lib/node_modules/element-theme

npm rebuild node-sass

后面基本可以了

et --watch --out ./theme